Homeland ruby-china 的 Android 客户端已经上架 GooglePlay 了

assyer · 2014年02月13日 · 最后由 xlgwr 回复于 2014年02月15日 · 2695 次阅读

Google Play

http://ruby-china.org/topics/17076

感谢@iBachue @ywjno @jimneylee

很喜欢社区,一年来通过社区获得了很多,这个开源的客户端就当是对社区的回馈吧~

赞!

如果能用这个项目为例子,写给像我这样的 android 小白一个开发教程, 并放在 leanpub 出版的话,我愿意付费。

在我的 Note 8 上,能够登陆,问题是一点一个帖子就退出 不知道是不是跟我用 CM11 有关

#2 楼 @AlphaLiu 额,果然还是会碰到兼容性问题。。。 #1 楼 @Peter 这个其实我也只是基本的应用而已啦,谷歌现在的官方指导已经做得很棒了,绝对是最好的学习资料https://developer.android.com/develop/index.html

#3 楼 @assyer 因为我用的是 CM 的 nightly build,所以本身就非常不稳定了。无所谓了,这应该是系统问题。

非常感谢

楼主发个 Android 应用调试教程出来 说不定大家可以帮忙测试下崩溃原因 靠楼主一个人不可能解决所有 Android 兼容问题的

评论里面有markdown格式的内容的时候没有正确渲染,,,

#4 楼 @AlphaLiu 我了个去,刚刚测了一下,居然这么悲惨。。。。 http://realauto.testin.cn/nativeapp.action?op=Report.testRecap&adpId=2867490 #6 楼 @iBachue 我主要是为了使用很多高级特性的 API,只要是 Nexus5 能跑着的都上了,最新的 4.4 系统 Kitkat,果然就遇到了兼容性问题

#7 楼 @ywjno 我渲染 markdown 是用 webview 来的,我怕内存不够。。。

#9 楼 @assyer 要是在程序转换 markdown 内容的话不知道是否可行呢?

#8 楼 @assyer 额 我建议你至少兼容到 Android 4.0。。Android 手机很多人不是不想升级 是真的没法升级。我当年那个 Android 手机还是 2.3 的,根本没法升到 4。

#7 楼 @ywjno 我突然想起来了,为了保证头像加载的流畅性,我把所有头像都缓存到内存里面去了。。。估计解决这个能解决一大部分兼容性问题。。。

#10 楼 @ywjno 应该也行,有个能解析 markdown 的组件 #11 楼 @iBachue 兼容到 4.0 应该问题不大。之前这个纯当是用来练手,特性都是怎么高级怎么来,完全不顾其他,自己 java 其实也只能算个半吊子水平,缝缝补补能用,真要涉及到更多内存管理 GPU 图形绘制什么的就歇菜了。。。

#15 楼 @assyer 貌似这个叫 pegdown 的不错,

#15 楼 @assyer 没事 好好做如果哪天找这方面工作就有强有力的作品了

要好好研究一下楼主的 code 了!

好人!

#16 楼 @ywjno 那个看起来很不错,但是不能用在 Android 平台上呢,不是我想要的貌似

#20 楼 @assyer 感谢,另外 1 楼 +1

刚下载下来,感觉还不错

so cool, nexus7 上使用问题不大

@xlgwr 二维码在这边呢,已经上架 google play 了

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册