• 看起来是提了段代码,但是具体从哪个版本开始还不明朗

    我目前在Unicorn+Sidekiq下运行了两周接近三周,没有遇到什么问题,中间还经历了从Rails 4.2 -> 5.1,一切正常,准备完全切换到jemalloc了

  • 对多线程有奇效,因为我并没有用Puma,所以不知道Puma的表现

    但是Unicorn也有至少15%的内存占用下降,我觉得很不错

  • 改的只是内存管理的部分吧... 目前已经跑了三天,没有看到什么异常,不过线上我是全部重新bundle的,gem也是全新编译。

    就你说的这个我还在CI上尝试了原版237的GEMS直接替换RUBY,不做重新bundle,CI也是全通过的。

  • Geeze now I don’t remember. I’ll kick it up again on Monday and see what happens. We were seeing some deadlocks at the same time because we were server side rendering react with execjs, so maybe jemalloc and V8 don’t get along. 是指这个?

    还是说ruby官方那个冗长的讨论...

  • https://bugs.ruby-lang.org/issues/13899 2.5好像没有类似的issue

  • 兼容问题是指怎样的表现?编译不能?运行有内存泄露?还是什么的... 不过我们估计不会直接上2.5,rails升级之后,稳妥点还是先上2.4.x