RVM/rbenv [结贴] 手贱,升级了一下 RVM,结果所有 Ruby 版本没了,也装不回。

jijin · 2013年03月26日 · 最后由 mike 回复于 2013年03月28日 · 14239 次阅读

今天升级了一下 rvm :

结果悲剧了,rvm 控制的 ruby 版本都没法用了,重装也装不上。

rvm -v rvm 1.19.0 (stable) by Wayne E. Seguin wayneeseguin@gmail.com...

折腾到现在,rvm 也重装过,无论装哪个版本都终端都提示一样的错误:

$rvm install 1.8.7 Searching for binary rubies, this might take some time. No binary rubies available for: osx/10.7/x86_64/ruby-1.8.7-p371. Continuing with compilation. Please read 'rvm mount' to get more information on binary rubies. Installing requirements for osx, might require sudo password. Skipping brew update make sure your formulas are up to date. Cowardly refusing to continue, please read 'rvm autolibs'.

...

$rvm install 1.9.3 Searching for binary rubies, this might take some time. No binary rubies available for: osx/10.7/x86_64/ruby-1.9.3-p392. Continuing with compilation. Please read 'rvm mount' to get more information on binary rubies. Installing requirements for osx, might require sudo password. Skipping brew update make sure your formulas are up to date. Cowardly refusing to continue, please read 'rvm autolibs'.

实在不知道问题出在哪,以前都是装好 rvm 后一个命令就将想安装的版本安装好,现在却报什么二进制安装包的错,google 的那些方法没发现能解决的,求大牛打救。 系统:10.7.4 Xcode: 4.5

就这样莫名的解决了: 执行:

$rvm requirements Installing requirements for osx, might require sudo password. Skipping brew update make sure your formulas are up to date. Cowardly refusing to continue, please read 'rvm autolibs'.

报错了; 然后我执行:

rvm autolibs

按里面的说明,执行了一下几句:

$rvm autolibs brew $rvm autolibs homebrew $rvm requirements

这样以后,ruby 的版本都能装了。 感谢各位的建议。

看最后一句,最后一句解决完了更新一下 homebrew,再然后看看 CLI Tools 是不是有新版了,另外把 rvm 本地的 cache clean 掉。一般就是这些问题。

Mac 好辦,刪掉 ~/.rvm ,然後從 Time Machine 裏面恢復你升級之前的 ~/.rvm 目錄。 千萬別告訴我你沒開 Time Machine ...

看到 lz 环境跟我一样,我也就试了试,发现这是真的,木有办法安装 ruby 了

不过还好 rvm 里面有个老版本的 1.9.3,我就从 2.0 切换到这个版本上了

初步怀疑是 xcode 版本太低造成(现在出到 4.6.1 而机器现在用的是 4.6)

ps:输入rvm requirements也会告诉你那个错误,很神奇啊。。。

错误提示都那么明显了还不会看的话,我觉得不适合做程序员。

#5 楼 @fredwu 有那么明显我就不来丢人了,当然是都试过了不行才求救。

2 楼只是在逃避问题吧

#4 楼 @ywjno 尝试过,

$rvm requirements Installing requirements for osx, might require sudo password. Skipping brew update make sure your formulas are up to date. Cowardly refusing to continue, please read 'rvm autolibs'.

我系统崩溃了,新装了 rvm,1.19.0 版本,rvmrequirements 出现相同的问题,解决办法是 rvm autolibs read-only rvm autolibs enable 两条命令

rvm install ruby-2.0.0 --autolibs=enabled

这样就可以了

sileixinhua MAC 下 rvm install 2.1.0 出错 提及了此话题。 04月03日 10:57
需要 登录 后方可回复, 如果你还没有账号请 注册新账号