新手问题 安装了 RVM 后原来安装的 Ruby 要卸载吗?

jokergaming · 2017年10月11日 · 最后由 jokergaming 回复于 2018年02月05日 · 2762 次阅读

我不久前刚刚开始学习 ruby, 当时用的 linux 系统直接就用包管理器安装了 ruby2.4。

后来随着代码量的增多,要安装不同版本的 ruby 和很多的 gem, 因为怕安装太多会出现各种依赖问题, 所以今天想用 rvm 来管理。

所以想问一下大家, 我 rvm 安装好了以后是不是要卸载原来系统安装的 ruby, 或者怎么把原来的 ruby 移动到 rvm 里面给 rvm 管理?

还有如果安装了很多 ruby 版本在 rubymine 里面怎么切换?

不需要。

不需要卸载原来的 ruby 的

rvm 安装成功后会有提示,根据提示运行命令,从而加入到系统变量里:

source /Users/XXXX/.rvm/scripts/rvm

安装 ruby:

rvm install ruby

或者跟版本号

rvm install ruby-2.4.1

查看 ruby,查看当前 ruby: rvm list,rvm current

设置默认 ruby:

rvm --default use ruby-2.4.0
zhangzitao 回复

谢谢, 知道了, 已经安装好了 rvm 和 ruby

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册