部署 遇到怪事一枚,求教

jarorwar · 2014年01月07日 · 最后由 jarorwar 回复于 2014年01月08日 · 2089 次阅读

同一个机器,1.9。3 的 ruby 就可以执行 bundle install ,一切正常, 但是 2.0.0 的执行 bundle install 连那个 fetch from 。。。 都不出来 大家看看是怎么会是?

源改成 taobao 的试试?

#1 楼 @heliang7 改了啊。不管是那里的 fetch from 总是回出现的,然后才是各种信息,现在连这个 fetch from 都不出现了

多个版本的 ruby,你用的是 rvm 管理的? 我 rvm 上 1.9 到 2.1 都可以 bundle。

#3 楼 @heliang7 是。我本机也可以,换了一台机器就不行了。是不是要重新安装 rvm?

这那是看看, 完全是猜猜么? 😉

淘宝的 http 不要加 s

rvm 的话, NOEXEC_DISABLE=1 bundle install 试试看?

@heliang7 @user_tony @xiaoronglv @luikore 非常感谢各位大大的关注,问题已经解决,我重安装了 rvm,然后一切就正常了!再次感谢! @luikore 您的方法沒试,因为我是重装了才看到的! 还是非常感谢

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册