开发工具 Homebrew 在 OS X 10.9 GM 里正常了吗?

kgen · 2013年10月17日 · 最后由 perrywky 回复于 2013年10月26日 · 5985 次阅读

Homebrew 之前不兼容 OX X 10.9 的各个测试版,部分组件无法编译,要自己手动折腾。

请教一下论坛里那么多装了 10.9 GM 版(目测 22 日发布正式版就是它了)的朋友们,Homebrew 在这个版本里面完全正常了吗?

正常啊,DP 就正常

正常 xcode 5.0.1 和 command line tools 都装好

#2 楼 @xi4oh4o 求 xcode 5.0.1 谢谢

Warning: You are using Mac OS X 10.9. We do not yet provide support for this (unreleased) version.

GM 依旧

另外

Apple dropped libstdc++ on OS X 10.9 and symlinked it to libc++

所以新安装转软会出现一些依赖问题

只能删除以前编译的包,然后用新的重新编译

#4 楼 @kevinzhow 悲伤……

最后一句的意思是,全部重新编译可解决?

mysql 不能装诶

有些 gem 编译不鸟,还有 mysql 装不起。。。

我都是 10.8 先配好环境 再升 10.9 这样就哦了

10 楼 已删除

#8 楼 @shawnyu #9 楼 @shawnyu

mysql 这样可以安装成功:

$ brew install apple-gcc42
$ brew remove cmake
$ brew install --use-gcc cmake

$ brew install --use-gcc mysql

# Cleanup
$ brew remove cmake
$ brew remove apple-gcc42
$ brew install cmake

见:https://github.com/mxcl/homebrew/issues/22021

#11 楼 @tsl0922 好办法,这样岂不是所有不兼容新编译器的组件,都可以这么搞定了。

MacVim 好像依旧是安装不能。

我准备 10.9 正式出的时候重装一个全新的系统。

TextMate 目前不可用

#14 楼 @welsonla TextMate2 正在使用

今把把东东都更新了,应该一切 OK 了

#15 楼 @zmbacker 我去 github 下个最新版试试

macvim : 用这个 patch https://github.com/mxcl/homebrew/pull/20473/files vim 在最新的 brew 中已经更新可以安装了

textmate2 可编译

#19 楼 @leeboqiang 这样是能安装,但是奇怪的是安装后的 macvim 不支持 ruby,使用:ruby 1会报错,也就不能用 command-t 了

需要 登录 后方可回复, 如果你还没有账号请 注册新账号