新手问题 Rails 4 上 gem ‘pg' 报错

chairy11 · 2013年05月16日 · 最后由 iBachue 回复于 2013年05月29日 · 2752 次阅读

“ An error occurred while installing pg (0.15.1), and Bundler cannot continue. Make sure that gem install pg -v '0.15.1' succeeds before bundling.”

是不是意味着 Heroku 上暂时不能跑 Rails 4 的项目?

我之前不是跟你说过么。。。这种地方支持的都是稳定版本吧。。。

#1 楼 @aisensiy 额,好吧……反正我先用 Rails 4 写了,然后希望它快点变正式版,然后快点被 Heroku 支持…… 你知道,偶是有升级癖好的……今天把 rubymine 啦 ruby(P195)啦 Rails 啦,能升的都升一遍……

呃,rails 4 现在还有很多 gem 不支持哦,虽然我也安装了,开发的时候还是用 rvm 切换到 gem default ^ ^

rubymine,很贵的说。。。

这两天看了下 android 的时候才知道版本坑爹死

晕,忘了发过这个帖子。 貌似我应该用 “bundle install --without production ”

pg 装不上么? 要先装 postgresql 然后

ARCHFLAGS="-arch x86_64" gem install pg -v '0.15.1'

再 bundle 应该就好了, 和 rails 兼容没关系...

是的 pg 的安装依赖一些东西,别说 Rails 4,Rails 2 也一样啊

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册