Git github.com 打不开了,网站没办法上线了,哭死-_-!

jeky · 2013年01月25日 · 最后由 jeky 回复于 2013年01月25日 · 7177 次阅读

询求帮忙!感激!!

[root@colud www.dousile.com]# bundle exec rake db:create rake aborted! Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. /usr/local/rvm/gems/ruby-1.9.3-p362/gems/execjs-1.4.0/lib/execjs/runtimes.rb:51:in autodetect' /usr/local/rvm/gems/ruby-1.9.3-p362/gems/execjs-1.4.0/lib/execjs.rb:5:inmodule:ExecJS' /usr/local/rvm/gems/ruby-1.9.3-p362/gems/execjs-1.4.0/lib/execjs.rb:4:in <top (required)>' /usr/local/rvm/gems/ruby-1.9.3-p362/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:inrequire' /usr/local/rvm/gems/ruby-1.9.3-p362/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in <top (required)>' /usr/local/rvm/gems/ruby-1.9.3-p362/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:inrequire' /usr/local/rvm/gems/ruby-1.9.3-p362/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in <top (required)>' /usr/local/rvm/gems/ruby-1.9.3-p362/gems/coffee-rails-3.2.2/lib/coffee-rails.rb:1:inrequire' /usr/local/rvm/gems/ruby-1.9.3-p362/gems/coffee-rails-3.2.2/lib/coffee-rails.rb:1:in <top (required)>' /usr/local/rvm/gems/ruby-1.9.3-p362@global/gems/bundler-1.2.3/lib/bundler/runtime.rb:68:inrequire' /usr/local/rvm/gems/ruby-1.9.3-p362@global/gems/bundler-1.2.3/lib/bundler/runtime.rb:68:in block (2 levels) in require' /usr/local/rvm/gems/ruby-1.9.3-p362@global/gems/bundler-1.2.3/lib/bundler/runtime.rb:66:ineach' /usr/local/rvm/gems/ruby-1.9.3-p362@global/gems/bundler-1.2.3/lib/bundler/runtime.rb:66:in block in require' /usr/local/rvm/gems/ruby-1.9.3-p362@global/gems/bundler-1.2.3/lib/bundler/runtime.rb:55:ineach' /usr/local/rvm/gems/ruby-1.9.3-p362@global/gems/bundler-1.2.3/lib/bundler/runtime.rb:55:in require' /usr/local/rvm/gems/ruby-1.9.3-p362@global/gems/bundler-1.2.3/lib/bundler.rb:128:inrequire' /opt/web/www.dousile.com/config/application.rb:7:in <top (required)>' /opt/web/www.dousile.com/Rakefile:5:inrequire' /opt/web/www.dousile.com/Rakefile:5:in <top (required)>' /usr/local/rvm/gems/ruby-1.9.3-p362/bin/ruby_noexec_wrapper:14:ineval' /usr/local/rvm/gems/ruby-1.9.3-p362/bin/ruby_noexec_wrapper:14:in `

' (See full trace by running task with --trace)

跟 github 没关系,是缺少 js runtime。装个 Node.js 应该就行了。

再者,github 貌似已经解封好几天了。

sudo apt-get install nodejs

#1 楼 @blacktulip 我指了 hosts 依然不行哟:

#4 楼 @jeky 错误 118 (net::ERR_CONNECTION_TIMED_OUT):操作超时。

#2 楼 @zhaowenchina 哪里的消息,我这边还是打不开。指不指 hosts 都不行 -_-!

#3 楼 @kungs 我来试下哈!谢谢了!~

http://ruby-china.org/topics/8297 其实关 github 什么事?很明显你是 ubuntu?照三楼的做吧

#8 楼 @AlphaLiu 我在北京,解析出来的地址是这个:207.97.227.239 , 的确是不行。我一会儿试下其他 ip。

感谢大家的帮忙,的确和 github 没有关系。现在已经可以了!!谢谢各位!!

我是 centos 系统,添加了一个 gem 后就可以了:gem 'therubyracer' 参考文档: http://stackoverflow.com/questions/9057475/rake-dbcreate-could-not-find-a-javascript-runtime

乱说,关 Github 啥事

oh sorry, only read the title...

#11 楼 @huacnlee 😆 我是新手,不好意思哈~

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册