Rails sqlite to postgreSQL 使用 taps 时报错,求大神们帮助

roam · 2013年01月21日 · 2381 次阅读

从 sqlite 到 postgreSQL 时,用 taps ,建立 server 的时候,报错,google 了好久没有找到具体的解决方式,请问有没有碰到同样问题的大大呢,求解决方案

C:\Project\DeliveryTools\DeliveryManagementTaskBoard.com>taps server sqlite://db/development.sqlite3 delivery delivery C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/lib/sequel/ad apters/sqlite.rb:62:in initialize': SQLite3::CantOpenException: unable to open database file (Sequel::DatabaseConnectionError) from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/adapters/sqlite.rb:62:innew' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/adapters/sqlite.rb:62:in connect' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/database/misc.rb:45:inblock in initialize' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/connection_pool.rb:92:in call' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/connection_pool.rb:92:inmake_new' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/connection_pool/threaded.rb:126:in make_new' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/connection_pool/threaded.rb:112:inavailable' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/connection_pool/threaded.rb:102:in block in acquire' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/connection_pool/threaded.rb:146:inblock in sync' from internal:prelude:10:in synchronize' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/connection_pool/threaded.rb:146:insync' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/connection_pool/threaded.rb:101:in acquire' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/connection_pool/threaded.rb:74:inhold' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/database/connecting.rb:226:in synchronize' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/adapters/sqlite.rb:94:inexecute_ddl' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/database/schema_methods.rb:320:in create_table_from_generator' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/database/schema_methods.rb:94:increate_table' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/plugins/schema.rb:24:in create_table' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/sequel-3.20.0/ lib/sequel/plugins/schema.rb:33:increate_table!' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/taps-0.3.24/li b/taps/db_session.rb:20:in <top (required)>' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/site_ruby/1.9.1/rubygems/custo m_require.rb:36:inrequire' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/site_ruby/1.9.1/rubygems/custo m_require.rb:36:in require' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/taps-0.3.24/li b/taps/server.rb:4:in' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/site_ruby/1.9.1/rubygems/custo m_require.rb:55:in require' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/site_ruby/1.9.1/rubygems/custo m_require.rb:55:inrequire' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/taps-0.3.24/li b/taps/cli.rb:61:in server' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/taps-0.3.24/li b/taps/cli.rb:27:inrun' from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/taps-0.3.24/bi n/taps:6:in <top (required)>' from C:/RailsInstaller/Ruby1.9.3/bin/taps:19:inload' from C:/RailsInstaller/Ruby1.9.3/bin/taps:19:in `

'

暂无回复。
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册