Gem 求助。。passenger 没法找到 bundle 安装的 git 源的 gem

bony · 2012年01月09日 · 最后由 beiersi 回复于 2012年07月18日 · 3516 次阅读
***                                                                                                                    Exception   
PhusionPassenger::UnknownError in PhusionPassenger::Rack::ApplicationSp                                                                                                                           awner (git://github.com/ryanb/nested_form.git (at master) is not checked out. Pl                                                                                                                           ease run `bundle install` (Bundler::GitError)) (process 26095, thread #<Thread:0                                                                                                                           x99fbf38>):

项目中用到了 nested_form,因为要和 simple_form 整合,所以就用了那个 git://github.com/ryanb/nested_form.git 。在本地 thin 测试,木有问题,但是部署到服务器上,passenger 就报错了。。纠结。求各位有知道怎木办的吗? @huacnlee @lgn21st @hooopo @fredwu @Rei

bundle install --deployment

@Rei 3Q so much 能麻烦你解释一下为什么?

@Rei 我前面 bundle install 也装成功了,而且 bundle show 也能找到

#3 楼 @bony passenger 的 ruby 环境和用户登录的环境是不同的,找不到 gems。知道--deployment 这个方法后我也懒得找其他方案了。

@Rei 哦,原来是这样。还是谢谢。。

我也刚碰见这个问题,不过这个办法会把 gem 一股脑的装在 vendor/bundle 下

需要 登录 后方可回复, 如果你还没有账号请 注册新账号