新手问题 RVM 下面的 bundle install 失败

ntoskrnl · 2012年09月29日 · 最后由 lgn21st 回复于 2012年09月29日 · 5143 次阅读
gemsets for ruby-1.9.2-p290 (found in /home/yuf/.rvm/gems/ruby-1.9.2-p290)
   (default)
=> docs
   global

yuf@ubuntu:~/cf-docs$ bundle install
ERROR: Gem bundler is not installed, run `gem install bundler` first.
yuf@ubuntu:~/cf-docs$ gem install bundler
Successfully installed bundler-1.2.1
1 gem installed
Installing ri documentation for bundler-1.2.1...
Installing RDoc documentation for bundler-1.2.1...
yuf@ubuntu:~/cf-docs$ bundle install
ERROR: Gem bundler is not installed, run `gem install bundler` first.
yuf@ubuntu:~/cf-docs$ rvm gemset list
yuf@ubuntu:~/cf-docs$ which bundle
/home/yuf/.rvm/bin/bundle
yuf@ubuntu:~/cf-docs$ bundle
ERROR: Gem bundler is not installed, run `gem install bundler` first.
yuf@ubuntu:~/cf-docs$

rvm 下面做了一个名叫 docs 的 gemset,也安装了 bundler,但是就是死活做不了 bundle install。手工安装了 gem,但是似乎有问题。

哪位大神遇到过类似的问题?

我觉得你的 RVM 安装有问题,照道理当你通过 RVM 安装好 Ruby 后,会自动帮助你安装好 bundle,而无需你自己单独安装。简单的解决方法时让 RVM 自爆,然后重装 RVM 和 Ruby 吧。

rvm implode
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册