部署 部署是遇到的问题,求高人指点一下啊

tomwey · 2012年08月13日 · 最后由 tomwey 回复于 2012年08月15日 · 2319 次阅读

用 cap 部署时出现了如下的问题: Could not find libv8-3.3.10.4 in any of the sources

请问是怎么回事呢?

Linux 平台么?试试看安装一下libv8-dev这个包。

好的 我的系统是 ubuntu11.10

nginx+rvm+mysql

还是不行呢

执行 cap deploy:check 时说 You appear to have all necessary dependencies installed

http://stackoverflow.com/questions/9038350/bundle-install-issue-with-libv8-and-rails

手工登录系统,看一个安装的版本是 32/64bit。大体就是这个问题。

@xds2000 这个怎么解决呢?

@tomwey

ruby-1.9.3-p0 :001 > `gem list`.each_line {|line| `sudo env ARCHFLAGS="-arch x86_64" gem install #{line.split.first}`

overflow 和你遇到的问题是一样的,你可以参考。

@xds2000

请问是直接在 Server 上执行这个命令还是在开发机上啊,对 cap 部署的原理不是很懂哈。

应该是 SERVER @tomwey

哦,我试试呢

谢谢!!!

需要 登录 后方可回复, 如果你还没有账号请 注册新账号