瞎扯淡 怎么最快让一个老版本的 application 跑起来?

dfang · 2012年08月09日 · 最后由 dfang 回复于 2012年08月09日 · 2761 次阅读

有时候,想运行看下别人的应用程序看看, 比如这个http://railscasts.com/episodes/241-simple-omniauthhttps://github.com/lgn21st/oauth2-provider-site 但是自己的环境是最新的(ruby :1.9.3p194,rails:3.2.7) bundle install 就过不了,这时候是删掉 Gemfile.lock 好呢,还是改 source 去 rubyforge 等地方下载呢?

rvm 建 gemset

如果需要 Ruby 1.8.7,

rvm --create --rvmrc 1.8.7@mygemset 用 Ruby 1.8.7 并且创建新的 gemset, 并把设置保存在.rvmrc 文件里

bundle

smile :)

这个为啥是瞎扯淡?

@hhuai 有装 rvm , 但是不想运行一个小程序就得去装一个老版本的 ruby 环境和 rails

@knwang 呵呵,有点像瞎扯淡,因为没有问具体的问题

需要 登录 后方可回复, 如果你还没有账号请 注册新账号