部署 重装 Ruby 2.5.1 之后启动报错

yu7272yu · 2020年11月10日 · 最后由 pathbox 回复于 2020年11月20日 · 208 次阅读

卸载重装 ruby2.5.1 版本,本地启动失败

  ruby -v
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-darwin19]
  rails -v
Rails 5.2.1

但是当我 rails s 启动的时候就报错(我也不懂我怎么就突然重装 ruby,之前是正常的。。)


/Users/liyujie/.rvm/gems/ruby-2.5.1/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require': dlopen(/Users/liyujie/.rvm/gems/ruby-2.5.1/gems/pg-1.1.3/lib/pg_ext.bundle, 9): Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib (LoadError)
  Referenced from: /usr/local/opt/postgresql/lib/libpq.5.dylib
  Reason: image not found - /Users/liyujie/.rvm/gems/ruby-2.5.1/gems/pg-1.1.3/lib/pg_ext.bundle

/usr/local/opt/openssl/lib/ 这个目录下面看看有没有安装 openssl,如果没有安装,就执行 brew install openssl

如果安装了,就看一下目录下面应该有最新版本的 libssl.1.0.0.dylib, 例如我这里最新版栮是: libssl.1.1.1h.dylib

然后将最新版本的这个文件做一个符号链接: ln -s libssl.1.1.1h.dylib libssl.1.0.0.dylib

可能这个目录里的其他几个文件也需要做,可以根据错误提示做上就好了。

@brookepowell 可以了哎,厉害

刚遇到相同问题,估计是升级的时候,把 OpenSSL 给升级了,但是pg-1.1.3/lib/pg_ext.bundl 这边还加载需要 libssl.1.0.0.dylib

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册