Mac 今天被提醒 OS X 10.9 无法升级 chrome 最新版了,还有多少坚持 10.9 的?

gaicitadie · 2018年04月19日 · 最后由 ruchee 回复于 2018年04月22日 · 5751 次阅读

如果不是换新笔记本,不打算升了,准备 10.9 一条道用到黑

不升级的理由是什么?

darkbaby123 回复

1、速度,基本不会卡顿,听说 10 以后经常会有卡顿,更耗资源
2、UI,感觉后来的版本 UI 变得繁杂了,失去了苹果原本的简洁

  1. 如果不是很老的 mac 基本可以放心。我 12 年的 macbook 用到去年,一直都是升级到最新的版本没问题。不过周围也有少数出意外的(基本是比我更老的),备份一次数据再做比较好。
  2. 这是既定事实,无法改变。不如调整自己的心态接受。

作为软件开发者,我觉得不更新是没法接受的。这意味着没有新特性,bug 不会修复,并且迟早会被抛弃。

现在用 ruby 还没感受到不便,我不开发 ios,现在受到的影响有:
1、.Net Core 无法安装,无法在 mac 上体验 jetbrains 的 IDE 开发 C# 了,只能开虚拟机用 vs.net,好在基本上不用.NET 开发服务器端,只是用来写一些简单的 winform 软件。
2、PHP7 无法安装,好像是某个 ssl 库在 10.9 上装不上了,现在基本上本地也用不到 php7 的新特性,在本地用 php6 服务器上装 php7 就可以,基本上也没有兼容问题。
3、比较新的 mac 版微信用不了,现在只能用较早的版本,无法存储聊天记录,这个问题挺头疼的。
4、Paste 只能用 2.x 版本,新版的一些功能很实用,不过 2.x 已经满足我的需求了。

随着时间的推移,各种不便可能都会接踵而至,但总体上影响不大,感觉再战 5 年还可以。

10.9 和 10.13 差 N 多个版本...

每次不敢升级是怕新版本对有些 gem 有影响,还维护着比较老的项目。原先一升级好几个 gem 就不能用了。。。。

multiple 回复

这种问题其实没有必要担心,因为升级并且还用这些 gem 的又不止你一个人,如果真的有了问题上游肯定会很快修复的。你担心时间因素那么可以晚一点再升级,但没有必要不敢升级。

一般出新版本,马上升级的路过

苹果家的系统,可以晚升,不可不升

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册