新手问题 该用 Bootstrap 4 还是 3?

samport · 2018年03月28日 · 最后由 samport 回复于 2018年03月29日 · 12918 次阅读

Bootstrap4 现在也是正式版了,不知道对各种浏览器的兼容性有没有问题。新项目的话,该用版本 4 还是 3?大家一般都是用什么 gem 来集成到 rails 项目里?

4 吧,用 rubygems 的形式或者 webpack 都可以

用最新的。

可能我眼光比较老,当初只有 bootstrap2 给了我耳目一新的冲击,后来的 3 和 4 感觉都很平庸了

b4 用上了 sass,b3 b2 是 less,样式定制如果你需要做前端写的话,是有差别的。

b4 具有前端前瞻一些,看个人需求吧。

我查了一下,AdminLTE 还是基于 Bootstrap 3 的,据说很快也会推出基于版本 4 的。另一个管理界面的模板 SB Admin 2,已经是基于 Bootstrap4 的了。常用的还是 SB Admin 2,决定选择 bootstrap 4 了。

对于不懂前端的人来说,bootstrap 就是大神。

谢谢各位热心的建议!

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册