Ruby 圣诞礼物:Ruby 2.4.0 Released

sticnarf · 2016年12月25日 · 最后由 lgn21st 回复于 2017年02月12日 · 3459 次阅读

果然不负众望啊,每年圣诞节发个大版本,升~

不错不错

每年圣诞有惊喜

rails 5 能用吗?

#4 楼 @samport 亲测能用,Rails 5.0.1 上用没有问题,就是要无视下面的 warning

warning: constant ::Fixnum is deprecated
warning: constant ::Bignum is deprecated

有些 Gem 不兼容, 比如 binding_of_callers, 没发现有什么升级的必要

和 ActiveSupport 2.3 不兼容

Ruby 2.4 is about 9% faster than 2.3.3. Memory consumption is also reduced by about 10%.

https://gettalong.org/blog/2016/ruby24-performance-looking-good.html

gem 'therubyracer' 不能兼容 2.4

Christmas Driven Development.

Support OpenSSL 1.1.0 (drop support for 0.9.7 or prior)!

#9 楼 @lgn21st 已替换,谢谢。

#5 楼 @lgn21st 我升级成 rails5.01 后也是出现那个有什么办法能解决呢。

#13 楼 @cryjay2012 你知道 warning 对大多数程序员意味着什么? http://coolshell.cn/articles/1903.html 😅

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册