瞎扯淡 Rails 4.2.4 与 Mysql2

mr_night · 2015年10月14日 · 最后由 msg7086 回复于 2015年10月15日 · 1900 次阅读

给自己的 Tips: 在使用 Rails 4.2.4 时碰到如下问题: 在Gemfile里面已经声名来gem ‘mysql2’结果还是提示你需要增加mysql2. 原因貌似是 Rails 4.2.4 所使用的 adapter 还不能支持 mysql2 gem 的最新版?

http://stackoverflow.com/questions/22932282/gemloaderror-specified-mysql2-for-database-adapter-but-the-gem-is-not-loade

解救办法按照帖子中说的: gem 'mysql2', '~> 0.3.18'

之前我也碰过这个问题。

gem 'rails', '4.2.4'
gem 'mysql2', '~> 0.3.20'
gem 'activerecord', '~> 4.2.4', require: 'active_record'

其实论坛里已经有至少 2 个帖子说到这件事了(

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册