新手问题 安装 win8.1+ruby2.1.6+rails4.2.3 x64 兼容问题,及 rails 的未来?

yan32768 · 2015年07月26日 · 最后由 ywjno 回复于 2015年07月26日 · 2285 次阅读

开始用 ruby2.2.2 版本,结果好多的 gems 运行时都报错,缺少文件,看了看 so 安装位置,很多都是 2.0.2.1 的,手工改一下目录名称不行。看 rubyinstaller 的帮助,安装 ruby2.1.x,结果顺利搭建好环境。

安装使用的都是 x64 版本,包括 devkit。不知道 rails 的未来怎样,从这些 gems 的维护时间看,很多都是 2 年以上没有更新过了,rails 真的不行了吗?

ruby 在 windows 下的开发者少,和未来不用扯上关系。

要怪就怪某些 gem 对 win 不友好,ruby 对 win 还是很友好的

3 楼 已删除
需要 登录 后方可回复, 如果你还没有账号请 注册新账号