新手问题 rvm 安装 ruby 之后,必须执行 /bin/bash --login 才能执行 ruby 命令

string2020 · 2014年08月27日 · 最后由 Teddy 回复于 2014年09月02日 · 4662 次阅读

每次打开一个终端之后,必须先执行 /bin/bash --login 才有 ruby 命令,否则,就找不到 ruby 命令

重启还是这样

rvm 命令,完全正常

请问,这是什么原因,什么问题,怎么解决

执行 /bin/bash --login 是在什么地方查到的?以及执行这个命令到底做了什么事情?

查看一下你的 terminal 程序, 有没有一个类似 Run command as a login shell 的选项, 把它选上试试

#2 楼 @Teddy 这种解决方法不好吧

echo '[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"' >>~/.bashrc
source ~/.bashrc
ruby -v

#2 楼 @Teddy 之前有遇到过,也是这么解决的,/bin/bash --login 应该是申明使用发布版本支持的 bash shell 吧

/bin/bash --login 是以 login shell 模式新开启一个 bash 进程而已。

2 楼的应该就是正确/最优的解决方案。

#8 楼 @colorfulberry 这条命令因该是你安装 rvm 后自动就添加到你的 .bashrc 或者 .bash_profile 中的。

谢谢大家,这个问题已经解决。 安装 rvm 后,默认是添加到 .bash_profile 里面的 改成添加到 .bashrc 就没问题了

#2 楼 @Teddy 小白请教,这个选项在哪里找呢? 如果不是命令行或手动添加的话。

#11 楼 @liheng 就在你 terminal 的设置里, iTerm2 的话就是 Preferences 的 Profiles 里, 其他终端类似

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册