新手问题 关于 ruby 的 rdoc 最新版本

woojuno · 2014年08月21日 · 最后由 woojuno 回复于 2014年08月21日 · 2041 次阅读

我是初看 programming ruby,其中使用 rdoc 有一句 shell:

ri GC

但是,我在命令行中敲击后并没有得到预想的结果,而是给出了 “Nothing known about GC”。 我在网上查了方法,需要安装 rdoc-data, 我就 gem 下载并安装,但是得到新的问题:

gem install rdoc-data
...
rdoc-data --install

结果:

Your ruby version 2.1.2 is not supported, only 1.8.7, 1.9.2, 1.9.3, 2.0.0

然后我就不知道怎么解决了,请问各位,谁能指导我下?

如果是 rbenv 装的 ruby, 装好后就有了 如果是 rvm 装的, rvm docs 就可以

#1 楼 @luikore 非常感谢,用 rvm docs generate 后就可以用了。

需要 登录 后方可回复, 如果你还没有账号请 注册新账号