新手问题 关于 ImageMaigck Ubuntu 环境下安装问题

wcc526 · 2014年07月21日 · 最后由 huacnlee 回复于 2014年07月21日 · 2726 次阅读

关于 imagemaigck ubuntu 环境下安装问题

imagemagick 到底是通过源码编译安装比较好,还是直接通过 apt-get install 比较好?

https://github.com/huacnlee/init.d/blob/master/install_packages

我发现论坛里两位大牛的做法相反 huacnlee 直接通过 apt-get install

但是 xdite 是 apt-get remove imagemagick ,然后从源码编译安装。

问下,哪种做法比较好。

本人试过,通过源码安装工作正常.

奇怪的是为什么 imagemagick 会出现两种安装方法,是因为 rmagick gem 支持版本的原因吗?谢谢!

既然工作正常了你还在纠结怎么安装干啥?

#1 楼 @flypiggys 强迫症患者,伤不起、

源码安装的版本比较新,可能有更多特性和性能优化,但是有安全漏洞的时候自己真的会关注并更新吗?

我也有强迫症啊,这很简单啊,看 apt-get 所安装的程序哪点不符合你的强迫症了...如果满足不了你,就编译安装来满足强迫症.否则就解决下一个让你犯强迫症的问题去....

imagemaigck 之前在 ubuntu 里有一个版本会丢失临时文件的 bug,而这问题一搜基本上会有结果。编译个最新的出问题可能就不是那么好解决了,而且还麻烦

折腾 ruby 就用 apt-get 罗,省事,省时间,我的 sublime text,atom,mysql,nginx 等等等等都是 apt-get 的,又方便升级。编译安装正常情况下也就三板斧嘛。

#5 楼 @flypiggys @Rei @saiga 好的,谢谢!我就是想弄清楚为什么有人要通过编译源码来安装 imagemagick,看来@xdite 的这篇 rails 生产环境软件的安装要更新了。https://github.com/rocodev/guides/wiki/setup-production-development

我那么做是找好了一个固定版本,系统版本,然后固定用它,这样部署可以一行命令搞完,省事

你需要就编译呗,目前 apt-get 那个版本够新,够用

需要 登录 后方可回复, 如果你还没有账号请 注册新账号