测试 [Capybara] 功能测试时 JS 驱动问题

jzlikewei · 2014年07月12日 · 最后由 ruby_sky 回复于 2014年07月14日 · 2404 次阅读

有支持 chrome 的 Capybara 驱动么 默认集成 selenium-webdriver 根本连不上 firefox,查了下有个 capybara-webkit 的 gem,居然还需要 qt 的库,这东西是要在本地用 qt 编译一个浏览器出来么.... 木有人用过直接操作 chrome 的么?我记得 AngularJS 测试默认带的那个就支持 chrome 的..... 还是说大家基本不写功能测试.... BTW,ruby-china 社区页面更新时上面的那一条红线是怎么实现的?

可以看一下 phantomjs

或许是版本不匹配的问题。这里有版本匹配说明: http://docs.seleniumhq.org/about/platforms.jsp

需要 登录 后方可回复, 如果你还没有账号请 注册新账号