新手问题 亲们主要用哪个版本的 Ruby?

lawrence · 2014年06月05日 · 最后由 heimirror 回复于 2014年06月06日 · 1769 次阅读

用最新版,一些软件的兼容性是否会存在问题?

用的最新的,暂时没遇到问题。

用最新的,旧版的兼容性有问题。

#4 楼 @lgn21st debugger gem 好像还不兼容

#2 楼 @Rei 在 windows 上也用最新版么?

#7 楼 @lawrence 我不用 windows 做开发,不清楚。

Ruby 这边都是追新的,Python 那边好可怜

#9 楼 @winnie 也就是 2.7 和 3.X 之类的吧 我还在用 2.7.....

各种版本.....................

#9 楼 @winnie 新版在语法上没有什么改变?兼容性上完全没问题?

#11 楼 @heimirror 要这么多版本做啥?

#13 楼 @lawrence 公司的老项目,没办法升级

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册