新手问题 Rails Tutorial Chapter 5 遇到的问题

yiming · 2014年05月22日 · 最后由 appell 回复于 2014年05月23日 · 2240 次阅读

Hi, 我在跟着 Rails Tutorial 走的过程中发现有些内容貌似过时了,比如 Bootstrap 现在已经 3.1 了。书里会让你在 Gemfile 里添加

gem 'bootstrap-sass'
gem 'sprockets'

并在 config/application.rb 里添加

config.assets.precompile += %w(*.png *.jpg *.jpeg *.gif)

这样一行以使得 Bootstrap 能和 Asset Pipeline 兼容。想问各位的是,现在有必要显式地在 Rails 4.1 的 Gemfile 里写上 Sprockets 么?此外这种 precompile 的选项需要打开么?我查阅了一下资料没有找到确切的回答。

另外一个问题:

Rails Tutorial 希望读者使用的各种 gem 的版本和其一致。但我还是坚持所有都用最新的 releases(Ruby 2.1, ails 4.1 各种)。初次接触 Ruby 和 Rails 应用开发,我还是希望与时俱进点。。。这是在作死么?

建议不要使用这种全栈的前端框架,你需要大量的时间去熟悉它的各种组件。。。。

#1 楼 @pynix 只是在跟着教程走一遍。。。Bootstrap 怎样我倒是不关心。

http://rubygems.org/gems/rails 的 Runtime Dependencies 中可以看到,包含了 sprockets-rails ~> 2.0,所以不需要的我们显示添加了

Rails Tutorial 已经在用 bootstrap 了呀

按照作者的版本来不会遇到多少错误(几乎没有),但这不一定是好事情。

需要 登录 后方可回复, 如果你还没有账号请 注册新账号