云服务 京东云有人尝试过了吗?

wormful · 2014年05月02日 · 最后由 cloudman 回复于 2020年03月26日 · 3275 次阅读

http://jae.jd.com/

创建应用的时候有 Ruby 支持。但创建后的默认网站貌似就打不开,自己尝试也找不到什么文档。

京东云是基于 CloudFoundry 的?但尝试之后有些错误信息怎么像是用的 Heroku 平台……(bundle install 里面还有到 heroku 的链接)

尝试过。。 之前用的时候不支持 rails4 现在应该已经支持了。 然后我搭了个 wblog 在上面。。

#1 楼 @hging 求经验……没文档你是怎么部署的……

#2 楼 @wormful 就是把程序丢 git 上。 然后改下数据库连接到京东云的数据库就可以了的呢。 你可以贴下报错给你看看。 应该是你的 gem 少加了两个。 这个比较坑。

#2 楼 @wormful 京东云是基于 cloudfoundry。会 vmc 就可以了。。

#3 楼 @hging

-----> Preparing app for Rails asset pipeline Running: rake assets:precompile
I, [2014-05-02T23:13:46.832469 #712] INFO -- : Writing /tmp/staged/app/public/assets/rails-9526610ae44d9e73134fd4337d78a4bb.png
I, [2014-05-02T23:13:51.736015 #712] INFO -- : Writing /tmp/staged/app/public/assets/application-b4840037661f6795b1a761f02057c19b.js
I, [2014-05-02T23:13:57.501932 #712] INFO -- : Writing /tmp/staged/app/public/assets/application-0de70a7e003de83ecb1841e8e31d75fe.css I, [2014-05-02T23:13:57.507180 #712] INFO -- : Writing /tmp/staged/app/public/assets/bootstrap/glyphicons-halflings-regular-147f3f6e098736e89ffab2c15cfbef06.eot I, [2014-05-02T23:13:57.507701 #712] INFO -- : Writing /tmp/staged/app/public/assets/bootstrap/glyphicons-halflings-regular-777bc40741c377d9f064d1ed31041f79.svg I, [2014-05-02T23:13:57.508240 #712] INFO -- : Writing /tmp/staged/app/public/assets/bootstrap/glyphicons-halflings-regular-38ab34013ba10653660d52a9cf85d53e.ttf I, [2014-05-02T23:13:57.545298 #712] INFO -- : Writing /tmp/staged/app/public/assets/bootstrap/glyphicons-halflings-regular-41eac767e76e3241f42674b78614369e.woff Asset precompilation completed (13.46s) Cleaning assets -----> WARNINGS: You have not declared a Ruby version in your Gemfile. To set your Ruby version add this line to your Gemfile:" ruby '1.9.3'" # See https://devcenter.heroku.com/articles/ruby-versions for more information." -- Include "rails_12factor" gem to enable all platform features See https://devcenter.heroku.com/articles/rails-integration-gems for more information.

这怎么看都给人一种 heroku 的感觉啊……

应该是不支持 4 的吧?前几天还试过。。。

速度倒是挺快的……就是文档奇缺。。。感觉已经坑掉了的样子……

刚整了一个,不支持 4

应用说明

JAE支持PHP语言。当前使用的Php版本是5.3.10
JAE支持Python语言。当前使用的Python版本是2.7.3
JAE支持Django框架。Django版本在运行时安装,请注意使用1.5.1之后的版本
JAE支持Wsgi接口的Python应用。
JAE支持Java语言。当前使用的Java版本是1.6
JAE支持Spring框架。当前使用的Spring版本是3.1.0.M2
JAE支持Ruby语言。当前使用的Ruby版本是1.9.3
JAE支持Rails框架。当前使用的Rails版本是3.2.11
JAE支持Sinatra框架。

#5 楼 @wormful WARNINGS: You have not declared a Ruby version in your Gemfile. To set your Ruby version add this line to your Gemfile:" ruby '1.9.3'" 然后把一些 gem 加进来。 可以参考 https://code.jd.com/jd_737f9e0d666bd/jae_wblogtest/blob/master/Gemfile 我的这个

需要 登录 后方可回复, 如果你还没有账号请 注册新账号