RVM/rbenv RVM 安装 Ruby 报错

johnlu · 2013年06月30日 · 最后由 xiaogui 回复于 2013年07月01日 · 10652 次阅读

系统:Ubuntu12.04 提示错误: There was an error while trying to resolve rubygems version for 'latest'. Halting the installation.

是什么原因?

删掉缓存试试? 下面 3 个目录里对应的 rubygems 都删一下

~/.rvm/archives
~/.rvm/src
~/.rvm/repos

再不行就加 --debug 参数看具体败在哪里

try "never use rvm"

参照 http://ruby.taobao.org/ RVM 改用本站作为下载源, 提高 Ruby 安装速度 FOR MAC $ sed -i .bak 's! ftp.ruby-lang.org/pub/ruby! ruby.taobao.org/mirrors/ruby!' $rvm_path/config/db FOR LINUX $ sed -i 's! ftp.ruby-lang.org/pub/ruby! ruby.taobao.org/mirrors/ruby!' $rvm_path/config/db

#1 楼 @luikore 谢谢! 虽然报错了,但还是能正常用 Ruby 和 gem。下次安装就用你这种方法试试

#2 楼 @andor_chen 为什么不用 RVM 呢?

#3 楼 @xiaogui 下载确实很慢。按照你这设置看看

#6 楼 @JohnLu 我在用这个之前,安装总是会卡住。用完以后异常顺利。

需要 登录 后方可回复, 如果你还没有账号请 注册新账号