瞎扯淡 从 RVM 到 rbenv 失败

RainFlying · 2013年05月25日 · 最后由 RainFlying 回复于 2013年05月26日 · 2984 次阅读

Debian 上早用 rbenv 了的, 昨天尝试把 OS X 上的 RVM 也换成 rbenv 结果编译 ruby 2.0.0-p195 失败了, ruby 2.0.0-p0 是没问题的…

不知道应该说什么,大概失败是成功他妈吧。

- -。还没有遇到失败的情况

假设你是用 ruby-build 编译的 Ruby,可以参考它的 wiki 来看看你遇到的问题是否有解决方案:https://github.com/sstephenson/ruby-build/wiki

#1 楼 @lgn21st 用 “它老母” 更好听来着…

#2 楼 @edgar_wang_cn 你在 Mountain Lion 下用 rbenv 编译 2.0.0-p195 的?

#3 楼 @5long Wiki 上只涉及到 2.0.0-p0 和 1.9.3 这些都是没问题, 我看了一下日志,大概是链接的 libruby 的库的问题。

#5 楼 @RainFlying 呃,不是,我的是 archlinux

#7 楼 @kenshin54 很久之前养过一只狮子兔

连个 log 也没有,也太不专业了吧

#8 楼 @edgar_wang_cn Linux 下毫无压力啊,我的 Debian 下就是编译安装无压力的

不妨给 ruby-build 开个 issue 吧~

#10 楼 @nouse 所以发在了瞎扯淡里嘛。这是用手机在上。

#12 楼 @5long 昨天翻了一下 issue 没看到,结合 Wiki 的内容,我就猜测新版本的 ruby 可能需要等段时间再做支持,于是就没发。其实我一直在 KVM 里的 Debian 上用 ruby 来着…

需要 登录 后方可回复, 如果你还没有账号请 注册新账号