• 升级 ruby 的 gem 环境问题 at 2019年03月09日

    😂 没事 谢谢哈~ 可能一年升级一次,或者使用的项目不多都手工了。。。我早上跑了一下 300 多 gem 二十来分钟遍历gem install安装了,但还是想看看有没更好的办法

  • 升级 ruby 的 gem 环境问题 at 2019年03月09日

    @Rei 好像没有表达好我的问题。。。我不是问一个项目的 gems 依赖,ruby2.5 里包含了多个项目的依赖,几乎都有用bundler,那不是要升级 ruby2.6 后,一一的进去项目bundler install? 这样好像还没有gem list出所有 gems,然后遍历gem install方便,并且也有些项目没有用 bundler 管理的,那用你的方法,有 bundler 的,我逐一进入bundler install,没有的则手工一个个gem install,这样就慢了,因为gem list本身可以列出所有已经安装的 gem 嘛,没有把这个列表直接导入自动安装吗?我是觉得可能有,但是我不知道,来问问看

  • 奖品说 1 月 17 日寄出,现在已经 11 天了,依旧没有收到,并且公众号问了也不回复的,感觉上当了,还被骗了个人信息。。。各位注意了

  • 但是 ruby 1.8.7 很多 gem 都不支持了。。。

  • 这样。。。谢谢提醒啊 那用 golang <=1.10.8 就好了吧。。。

  • 😬 感谢各位的回答~ 后面考虑到 ocra 的打包运行前还要解压,放弃了 ruby 打包运行的想法,因此不需要解决 win2k3 运行 ruby,改用 golang 实现。。。

  • 😀 谢谢啊 不过修改 dll 文件的话 影响不太好

  • 不是公司要求我用 windows 开发 ruby。。。我是要在拿到权限的主机中进一步的扩展内网,有一群人是需要在各种系统版本不定,环境不定的服务器上开发工具的,那群人的工作叫做——渗透测试

  • 😂 没有百万年薪,这可能就是为公司开发和自己玩的差距吧

  • mruby 写起来会不会跟 cruby 的差很大?而且好像也要编译,cruby 本身就支持 win2k3,我也是遇到编译问题。。。