新手问题 Ubuntu 下 bundle package 的 mysql2 错的

henry_huangs · 2012年11月19日 · 最后由 small_fish__ 回复于 2012年11月19日 · 4054 次阅读

ubuntu apt-get install 无法下载

使用 stackoverflow 上的解决办法 sudo apt-get install libmysql-ruby libmysqlclient-dev

ubuntu 更新,但是总是有几个包提示无法下载,

照着无法下载的路径找过去,发现在源里有没 5.5.24 只有 5.5.22,5.5.27,5.5.28.。。。。。。。。 很奔溃啊!!! 大神教教!

换一个源

我试了一下用 163 的源是可以的……

sudo apt-get install libmysqlclient-dev

正在读取软件包列表... 完成 正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包是自动安装的并且现在不需要了: libportaudiocpp0 使用'apt-get autoremove'来卸载它们 下列【新】软件包将被安装: libmysqlclient-dev 升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。 需要下载 1,393 kB 的软件包。 解压缩后会消耗掉 5,621 kB 的额外空间。 获取:1 http://mirrors.163.com/ubuntu/ precise-updates/main libmysqlclient-dev amd64 5.5.28-0ubuntu0.12.04.2 [1,393 kB] 下载 1,393 kB,耗时 0 秒 (1,868 kB/s)
Selecting previously unselected package libmysqlclient-dev. (正在读取数据库 ... 系统当前共安装有 434385 个文件和目录。) 正在解压缩 libmysqlclient-dev (从 .../libmysqlclient-dev_5.5.28-0ubuntu0.12.04.2_amd64.deb) ... 正在处理用于 man-db 的触发器... 正在设置 libmysqlclient-dev (5.5.28-0ubuntu0.12.04.2) ...

一定要 5.5.24 吗?

apt-get update 更新一下本地的索引然后再试试 apt-get install ... 去装?

gem install mysql2

Downloading http://rubygems.org/latest_specs.4.8.gz File already downloaded and cached to /usr/share/ruby-rvm/gems/ruby-1.9.2-p318/cache Downloading http://rubygems.org/quick/Marshal.4.8/mysql2-0.3.11.gemspec.rz ######################################################################## 100.0% Downloading http://rubygems.org/gems/mysql2-0.3.11.gem ######################################################################## 100.0% Building native extensions. This could take a while... Successfully installed mysql2-0.3.11 1 gem installed Installing ri documentation for mysql2-0.3.11... Installing RDoc documentation for mysql2-0.3.11...

然后就装上 mysql2 gem 了

是由于其 C++的编译器出了错误,使用此命令安装: sudo apt-get install libmysql++-dev

#2 楼 @qhwa 我也不知道为什么用那个命令后,他会下载 5.2.24 的,

#1 楼 @huacnlee 搜狐的,官方的,163 的我都看了,都没的

#6 楼 @henry_huangs 3 楼 @5long 说的对,估计你本地索引过期了,需要 apt-get update 一下

ubuntu12.10 今天装了两个都没有问题,呵呵

需要 登录 后方可回复, 如果你还没有账号请 注册新账号