Rails Rails 4.0.0.beta 来了。。。

roamlog · 2011年12月20日 · 最后由 RobinWu 回复于 2012年02月04日 · 4170 次阅读

dhh 说 rails 3.x 到 rails 3.2.x 为止就不往后了,现在 rails 已经在开发 rails 4.0 了,只支持 ruby 1.9.3 以上。。。

我叉 Rails 2.3.x Rails 3.2.x 都没过 4 啊

4.0 会有什么 nb 的特性?

#2 楼 @suupic 现在决定下的唯一特性就是不支持 1.8.7 了。

#3 楼 @hisea 这个特性最 NB

“ We’re simply doing this now because we’re dropping support for Ruby 1.8.7 in rails/master and people should know what’s up.”

我靠,有没有大致发布日期?

看来俺是跟不上 rails 的速度了,ruby 基础弄弄好吧

https://github.com/rails/rails/pull/505 这个 pull request 已经吵了很久了 4.0 一定会增加 patch verb 哇卡卡

更新速度远远快于学习速度 泪奔...

#8 楼 @hooopo 话说我看了 rfc2068,patch 跟 put 的不同就是会返回 diff.然后同样不是幂等的.. 然后直接用 patch 替代 put 呢? .. 有什么不妥? 那个 pull request 是增加一个 verb,而不是替代.

#10 楼 @Saito wok..突然花献这个 patch 是 dlee 打的. orz..

十月份才开始用 rails3.1 现在居然就 rails4.0 了。更新太快了吧

忒快了吧..

时代变的太快,跟不上了

需要 登录 后方可回复, 如果你还没有账号请 注册新账号