Gem lazy_high_charts 1.2.2 稳定版发布。画图就用它了

xds2000 · 2012年08月31日 · 最后由 xds2000 回复于 2013年11月01日 · 5503 次阅读

https://rubygems.org/gems/lazy_high_charts

  • Aug 31, 2012
    1. Correct highchart js location issue#74
    2. support series data add javascript event issue#73
    3. remove default html options. issue#72

很精美啊

挺好的,我最近的一个项目正好使用了你的 Gem 呵呵。 不过有一个问题(hight chart 的 ajax 显示)没有满足我的需求,我稍微修改了代码。 看是否可以在下一个版本加进去。 还有,是否能提供 highcharts 的 打印功能? :-)

@chucai 加打印功能,不错的建议。我下周加上。 ajax 想要啥效果,给个你改好的例子,让我了解需求后可以加。

楼主头像乍一看还以为是陈汉典呢

@xds2000 谢谢你的辛苦工作。。。 Ajax 的场景是这样的: 图表的代码,是 ajax 加载的。所以,是在 document 的 ready 之后。 我在 blog 上有说明: http://blog.csdn.net/hexudong08/article/details/7848547

#3 楼 @xds2000 最近项目也使用 high chart,后来找到了你写的这个 gem,正准备用。 这个 gem 和https://github.com/michelson/lazy_high_charts 是什么关系?

#6 楼 @camel 一家的。我是目前的维护者。

@chucai 宾构。用最新的 lazy_high_chart 1.2.2。直接有 AJAX 支持。你的代码我看了,其实有一个隐含 bug.我的版本已修正。

#8 楼 @xds2000 nice! 给力! 期待你的更新。因为我最近就需要打印的功能,哈哈。

@xds2000 请教一下哦, 我在安装的时候出现下面得错误。这是怎么回事啊 —————————————————————————————— ~/project/myapp$ rails g lazy_high_charts:install [WARNING] Could not load generator "generators/lazy_high_charts/install/install_generator". Error: uninitialized constant LazyHighCharts::Rails::Generators. /home/yangdn/.rvm/gems/ruby-1.9.3-p194/gems/lazy_high_charts-1.3.2/lib/generators/lazy_high_charts/install/install_generator.rb:4:in <module:LazyHighCharts>' /home/dd/.rvm/gems/ruby-1.9.3-p194/gems/lazy_high_charts-1.3.2/lib/generators/lazy_high_charts/install/install_generator.rb:3:in' /home/dd/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.8/lib/rails/generators.rb:300:in block (2 levels) in lookup' /home/dd/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.8/lib/rails/generators.rb:296:ineach' /home/dd/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.8/lib/rails/generators.rb:296:in block in lookup' /home/dd/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.8/lib/rails/generators.rb:295:ineach' /home/dd/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.8/lib/rails/generators.rb:295:in lookup' /home/dd/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.8/lib/rails/generators.rb:152:infind_by_namespace' /home/dd/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.8/lib/rails/generators.rb:169:in invoke' /home/dd/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.8/lib/rails/commands/generate.rb:12:in' /home/dd/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.8/lib/rails/commands.rb:29:in <top (required)>' script/rails:6:inrequire' script/rails:6:in `

' Could not find generator lazy_high_charts:install.

请问可以在 rails 上安装导出的服务么,我点击导出按钮是进 highchart 网站的

不错!

#11 楼 @hayate 这个问题,你需要修改它的源代码,很简单的。

#13 楼 @chucai 可以说的再详细点么。。

今天用了下,果断好用,但是我遇到一个业务上的问题。假设我有 10 个站要监控,并且监控频率为 1 小时,我需要绘制出各个站每个时刻的数据情况,例如: 但是我觉得这个数据库的查询太久了,我用 redis 做了缓存,但是感觉这不是一个好办法,请问有什么好的办法吗?

Installing lazy_high_charts (1.3.3) 
Gem::InstallError: lazy_high_charts requires RubyGems version ~> 1.3. Try 'gem update --system' to update RubyGems itself.
An error occurred while installing lazy_high_charts (1.3.3), and Bundler cannot continue.
Make sure that `gem install lazy_high_charts -v '1.3.3'` succeeds before bundling.

请问 Ruby2.0 后,为什么会出现上面的问题呢?

要做图,找到这个,挺好。

就是使用说明最好有写,要不然刚开始不知道怎么用。还是我没找到文档位置?

我是参考测试代码和 wiki 里面的案例才知道怎么用的。

@as181920 确实有这个问题,有 issue 在 track 它。稍后升级到 rails 4,我在改进。

你好 @xds2000 由于前期一个项目的修改,需要进行画图,很高兴看到这个 Gem 包,但是没有任何经验...我查看 document 的 user_guide 还没有任何内容,请问在哪里可以看到相关文档。另外,我现在版本是 ruby 1.8.7 rails 3.0.11 可以兼容么?谢谢

您好,下载图片时,中文乱码问题,应该怎么解决?

@331299 你提交一个 issue,把你的例子提交一下。我看看再说。

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册