新手问题 用 ubunru 的 sudo apt-get 安装 ruby 装错了版本,如何删除在重新装

Sunnyroger · 2012年07月31日 · 最后由 kevin__liu 回复于 2012年07月31日 · 5936 次阅读

大家都说 win 下面不好,于是转到了 ubuntu 下面,错误的选择了使用 sudo apt-get install ruby 之后才发现是 1.8 的,然后我用 sudo apt-get autoremove --purge ruby 来删除 ruby,可是删除后输入 ruby -v 显示 ruby 还在,并且还可以使用 irb 解析器,查了好多都不会,敢问哥哥姐姐们这个问题怎么破!!! 还有,再问一个使用 wiki 中的方法装 rvm,可是装不上啊。第一步就显示

% Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- 0:01:03 --:--:-- 0curl: (7) couldn't connect to host 哥哥姐姐们,怎莫破啊!^_^

ubuntu 的源里有个 ruby1.9.3 的包,装的话应该会自动替换/usr/bin/ruby 到新版本吧

@Asakawa 没有啊,我 sudo apt-get install ruby-1.9.3,显示没有这个包啊

#2 楼 @Sunnyroger 这要看你的 ubuntu 是什么版本了,你先用 sudo apt-get update 更新一下你的安装源。再用 apt-cache search ruby 搜索查看一下你的安装源中有哪些与 ruby 相关的包和版本。还可以用 apt-cache show ruby 来查看具体信息。

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册