Rails 想用 Rails 的 API 模式写后端 API,有没有可以生成最新版 swagger 文档的 gem?

jonnoj · 2018年08月13日 · 最后由 EvanYa 回复于 2021年10月21日 · 1525 次阅读

如题,不想用 grape,但目前找出来的能用的 gem 是swagger-docs,但只支持 2.0 版本。

想问一下有没有其他解决方案可以使生成最新版的 swagger 文档?


找到一个新 Gem,https://github.com/zuzannast/swagger_ui_engine

咦 - 不用 grape 不能用 swagger 嘛?,看看这个,https://ruby-china.org/topics/25822

sanm1992 回复

原文提到的 swagger-rails 已经不存在了,swagger-docs 就如我贴子中所说的,只支持到 2.0 版本。

需要 登录 后方可回复, 如果你还没有账号请 注册新账号