部署 请求帮助,我按照教程在 ubuntu14.04 上安装 ngnix + passenger,出现了包依赖错误,请大佬帮我看看。

jiuxueliang · 2018年06月02日 · 最后由 yuanchang 回复于 2019年11月25日 · 4653 次阅读

我照着 passenger 的官方教程: https://www.phusionpassenger.com/library/install/nginx/install/oss/trusty/ 然后执行到 sudo apt-get install -y nginx-extras passenger 命令时出现:

[email protected]:~$ sudo apt-get install -y nginx-extras passenger Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: nginx-extras : Depends: nginx-common (= 1:1.12.2-8.5.1.12~trusty1) but 1:1.14.0-8.5.3.1~trusty1 is to be installed Recommends: passenger (< 5.1.13) but 1:5.1.12-1~trusty1 is to be installed E: Unable to correct problems, you have held broken packages. [email protected]:~$

请问,该怎么办?Google 和百度了很久,重装了很多次都不行。

14.04 太老了,还有不到一年就停止维护。换 18.04 看看?

Rei 回复

亲测,ubuntu18.04 运行 sudo apt-get install -y nginx-extras passenger ,会出现 libperl 版本不支持安装啥的,建议使用 ubuntu16.04

需要 登录 后方可回复, 如果你还没有账号请 注册新账号