新手问题 看 D 大神的 ActionCable demo 演示的时候遇到了问题

ThanksSirAlec · 2017年11月21日 · 最后由 ThanksSirAlec 回复于 2017年11月21日 · 1188 次阅读

看到这步

应该在输入框里输入后会返回一个提示窗口,但是我遇到了下面的报错

全程跟着视频写的,请问这是什么问题

不知道你的 Rails 版本是多少,因为 Rails5.1 移除了 JQuery

liukun_lk 回复

额 5.1.4,请问这个要怎么解决,我接触 web 开发才一个礼拜,完全搞不明白

ThanksSirAlec 回复

如果要按照教程走,环境最好也是和教程一直。也能少些问题。或者把 jQuery 相应的 gem 加上去。

liukun_lk 回复

我在 gemfile 里面加了 gem 'jquery-rails' 然后在 application.js 里面加了//= require jquery3,//= require jquery_ujs 运行了 bundle install 但是还是报错,请问是漏加了什么东西吗还是加的不对

ThanksSirAlec 关闭了讨论。 11月21日 17:09
ThanksSirAlec 重新开启了讨论。 11月21日 17:09
liukun_lk 回复

问了一下朋友 application.js 文件里的顺序关系,现在好了,谢谢指点

ThanksSirAlec 关闭了讨论。 11月21日 17:20
需要 登录 后方可回复, 如果你还没有账号请 注册新账号