Nginx 配置了 https 后就返回 302 错误,自己捣鼓了快三天了,还不解决不了,请教一下各位。

apgeypeu · 发布于 2017年10月04日 · 最后由 bajiudongfeng 回复于 2017年10月05日 · 558 次阅读
96
#server
#   {
#   listen 80;
#   server_name www.test.com test.com;
#   return 301 https://$server_name$request_uri;
#   
#}




server {
#   listen 80;
    listen 443 ssl;
    server_name www.test.com test.com;
    index index.htm index.php index.html;
    root /home/www/test;
    ssl on; 

    ssl_certificate /etc/nginx/conf.d/cert/ssl.pem;
    ssl_certificate_key /etc/nginx/conf.d/cert/ssl.key;
    ssl_session_timeout 5m;
    ssl_ciphers ECDHE-RSA-AES128-GCM-SHA256:ECDHE:ECDH:AES:HIGH:!NULL:!aNULL:!MD5:!ADH:!RC4;
    ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    ssl_prefer_server_ciphers on;

    include enable-php5.conf;


    location /nginx_status {
        stub_status on;
    }

    location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
        {
            expires      30d;
        }

        location ~ .*\.(js|css)?$
        {
            expires      12h;
        }

        location ~ /.well-known {
            allow all;
        }

        location ~ /\.
        {
           deny all;
        }
    location /{
            if (!-e $request_filename){
             rewrite ^/(.*)$ /index.php?s=$1 last;
            }
        }
    access_log /home/wwwlogs/test001.log;
}

共收到 3 条回复
15999

删掉第二个 listen 80 看看

96

应该监听443端口,80端口重定向到https域名,还要设置加密证书,你提供的信息很不全。

14935

少了这个 ssl_dhparam

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册