Ruby Ruby v2.4.2 Released

ericguo for Faria · 2017年09月15日 · 最后由 dsh0416 回复于 2017年09月17日 · 1395 次阅读

https://www.ruby-lang.org/en/news/2017/09/14/ruby-2-4-2-released/

如果用brew upgrade ruby,安装完毕后,需要执行以下命令:

cd /usr/local/opt/ruby/lib
ln -s libruby.2.4.2.dylib libruby.2.4.1.dylib
共收到 4 条回复

An incompatibility has been found for Ruby 2.4.2. Ruby 2.4.2 can not link with libgmp nor jemalloc.

这样的话过几天要出 2.4.3 吧...

提交了相关版本发布记中文翻译的 PR 了,修复的问题还挺。。。不容易触发的。如果项目不涉及 libgmp 和 jemalloc 可以平滑升级,如果涉及这两个库还要手动打一下补丁😅

dsh0416 回复

你用 jemalloc 了?

jasl 回复

没用。。。我翻译版本发布记的时候看了下遇到的具体问题。。。 不过你这么一说我倒是可以试试这玩意,三年没维护这个 gem 了,有点虚。

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册