新手问题 有人在 deepin15.4 上成功安装了 Rails 开发环境吗?

shoushen · 2017年04月20日 · 最后由 laxselocke 回复于 2017年04月24日 · 2931 次阅读

deepin15.4 上用 rvm 安装,出现依赖错误。不知道有人安装成功的没?

可能你选择 Ubuntu / Debian 会更容易查到资料和获得社区的帮助,毕竟用户量大。

kgen 回复

答非所问

更换系统太麻烦 可以试试 Rbenv

出现依赖错误,什么错误?

如果能换服务器版本,建议换掉,在你不熟悉的时候,别折腾,用一个简单的途径。

你这个问题也是有意思的.

不知道有人安装成功的没?

我去年用的 deepin 安装成功过,不过版本忘记了.

为啥不把错误贴出来呢..

15.3 的时候我没问题

Why not copy and paste your err log in this post?

还是 Rbenv 好,安装很顺利。。。。

贴错误

我直接 apt-get install ruby ruby-dev 就行了。

github.com/postmodern/ruby-install

ruby-install --system -M https://cache.ruby-china.org/pub/ruby ruby 2.4.1

deepin 肯定是没问题的。这个配 ruby 环境和操作系统关系不大呀,一般就是包依赖的问题解决就好了。

可以下载源码安装

前两天深度上安装成功

出现依赖错误就单独 apt 那个包 加上 ruby-包名

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册