RVM/rbenv Ruby 指定不了当前版本

xiaobai2 · 2016年11月25日 · 最后由 763914974 回复于 2016年12月01日 · 7505 次阅读

很奇怪,我要用 2.2.2 的版本怎么用不了,给我报了如上的错误

/bin/zsh --login

为什么还有人在用 RVM…

#3 楼 @xiaobai2 你先运行上面的命令再rvm use 2.2.2

#2 楼 @nouse 你们都是在用 rbenv 作为版本管理吗?

#6 楼 @yaocanwei 早前用 rbenv 不稳定,然后就回来用 rvm, 现在懒得折腾了, 话说是两年前的事儿了;

rvm 不好用吗,我还在用 rvm 呢

#2 楼 @nouse 你这个吐槽。。。。有点过了吧

shell 分是否 login 模式

#1 楼 @w7938940 我之前也遇到过 为什么会有这样的提示呢?

Shell 不是 bash 导致的。 zsh 之类的,要加 rvm 的初始化代码到 dotfiles 里面。

每次看到这种问题,我都想问,为什么不看提示,为什么不去搜索。

需要 登录 后方可回复, 如果你还没有账号请 注册新账号