Gem 求问 Ubuntu 上 nio4r 的安装问题

rrrlly · 2016年10月13日 · 最后由 mimosa 回复于 2016年10月14日 · 2187 次阅读

OS:Ubuntu 16.04 启动 rails 服务器时提示: 提示安装 nio4r 1.2.1 安装后出现问题:

然后再启动服务器还是不行,进入了这个循环😓

你这截图显示的是 gem 并没安装成功啊, 你可以到 stackoverflow 上搜一下相关信息啊

贴完整错误日志,不要截图!

  1. nokogiri 1.6.8.1版本不存在,可能是你用了 ruby-china 的 gem source,换 https://mirrors.tuna.tsinghua.edu.cn/rubygems/
    • 因为 ruby-china 的源不是实时同步的,会晚 2 天?
  2. nio4r 1.2.1的错误提示里写着, /usr/local/bin 目录没有写入权限,可以使用 sudo gem install nio4r -v 1.2.1
需要 登录 后方可回复, 如果你还没有账号请 注册新账号