云服务 Travis CI 中的 cURL 问题

helperhaps · 发布于 2016年09月13日 · 最后由 helperhaps 回复于 2016年09月18日 · 1014 次阅读
17324

惭愧, PHP 的一个包要支持使用 HTTP2 发送请求,使用 cURL 轻松的实现了。

但是我本地安装的是 PHP7 和 libcurl3-7.50.1 所以是没有问题的。但是大家都知道 PHP 的坑之一就是很多人使用的都是相当古老的版本甚至 5.3 以下的不版本。

所以这个 feature 的测试就要借助 travis-ci 的力量了(我是这么想得),在 Travis 配置文件中指定了 5.3、 5.4、 5.5、 5.6 和 7.0 这些版本来测试,根据 http://stackoverflow.com/questions/34606801/how-do-i-send-a-http-2-post-request-in-php 这个答案来看 PHP >= 5.5.24 cURL 就会使用 http2 发送请求。但还有一个要求是 libcurl >=7.38.0(一说大于 7.33.0),然后喜闻乐见的 travis 中的 libcurl 的版本在每一个 php 版本中都是 7.22.0 ,

那么问题来了,怎在 Travis 中升级 php-curl 所依赖的 libcurl 的版本呢,知道的大大指点一下,或者发个有用的链接我看看

共收到 5 条回复
865

所以为什么要在 Ruby 社区问 PHP 问题。。。

17324

#2楼 @yesmeck 这个是 travis 的问题啊,只是是 php 在使用 Travis 啊,就相当于 Ruby 的一个插件的系统依赖项版本太低,怎么在 Travis 中升级一个意思,看样子大家都没有遇到过啊 😢

865

travis-ci 可以自己安装包的吧,自己安装个新版的 libcurl 试试。

17324

#4楼 @yesmeck 试过了,安装的版本还是老版本,放弃了,不使用 travis 来测试新 feature ,人工测吧

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册