Rails Mac 安装 Rails 报错,不知何解,

galenzx · 2016年01月16日 · 最后由 easonlovewan 回复于 2016年01月18日 · 1711 次阅读

刚刚开始学习ruby ,在mac 上配置ruby 环境 出问题,求帮组,

参考https://ruby-china.org/wiki 中的教程配置的ruby 环境,

刚刚接触 ruby 对一些东西不了解,往谅解,

直接用mac 自带的ruby 环境 会不会对mac 系统的有影响,

还是用brew 重新自己构建一套 ruby 环境?

新手 ,希望朋友 给点意见

PS: 卸载mac 自带的 rvm rails环境有什么办法

共收到 10 条回复

差资料 折腾了一晚上 , 还没弄出来,

建议。安装rvm,用rvm安装高版本的ruby,然后用rvm安装的ruby进行开发。

#2楼 @judi0713 mac OSX 下的ruby 环境 用mac 系统自带的还是用brew 包管理器 管理ruby 环境

看wiki,右边第一篇讲安装的。rvm肯定可以的。

#3楼 @galenzx 我就是mac os,用rvm管理

我是用brew 安装的,之前 的那个版本太低了,,,

#7楼 @zhaopei rvm 还是rbenv,纠结不知道选哪个,第一次折腾

#8楼 @galenzx http://railsapps.github.io/installing-rails.html 親測沒有問題,應該是沒有用 rvm 的原因。

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册