Gem 请教一个 Gem 依赖问题,关于最新的 ruby-china 代码

huobazi · 2012年04月21日 · 最后由 huacnlee 回复于 2012年04月22日 · 3803 次阅读

gemfile

# Mongoid 辅助插件
gem "mongoid", "2.4.8"
gem "bson_ext", "1.6.2"
gem 'mongo-rails-instrumentation','0.2.4'
gem 'mongoid_auto_increment_id', "0.4.0"
gem 'mongoid_rails_migrations', '~> 0.0.14'
gem "mongoid_colored_logger", "0.1.1"


用 source 'http://ruby.taobao.org' 结果如下:

$ bundle update bson_ext
Fetching source index for http://ruby.taobao.org/
Bundler could not find compatible versions for gem "bson":
  In Gemfile:
    mongoid (= 2.4.8) ruby depends on
      bson (= 1.5.2) ruby

    bson_ext (= 1.6.2) ruby depends on
      bson (1.6.2)




我换成 用 source :rubygems 结果如下

$ bundle update bson_ext
Fetching source index for http://rubygems.org/
Could not find gem 'bson_ext (= 1.6.2) ruby' in any of the gem sources listed in your Gemfile.




是哪里有了问题呢?

有人起床了么?

bundle update bson_ext mongoid 就可以了

需要 登录 后方可回复, 如果你还没有账号请 注册新账号