Rails 在 Github 上看到一个两年前的 Rails App,如何判断对应的 Ruby 版本?

laoyuan · 2015年08月17日 · 最后由 nouse 回复于 2015年08月18日 · 1716 次阅读

https://github.com/robinbortlik/db_explorer 用 web 来管理 MySQL,类似于 phpMyAdmin。 bundle install 的时候报错了,因为 eventmachine 1.0.3 和 Ruby 2.2 不兼容。那么问题来了,如何判断相应的 Ruby 版本呢? rails (= 4.0.2)

2 楼 已删除

对于你这个特定的问题,那自然是要参考 eventmachine 的文档咯,其他的 gems 没有兼容性问题,因此 eventmachine 就成了下限,看它的文档就知道用什么版本合适了。

@nightire @flemon 谢谢两位,看来 Ruby 的版本并不是强关联到 Rails App 的,我用 Rvm 管理多环境试试

bundle update eventmachine

需要 登录 后方可回复, 如果你还没有账号请 注册新账号