Gem 运行 bundle install 之后 每次都要求装一个又一个 gem 不停提示

sensi · 2015年03月15日 · 最后由 awking 回复于 2015年03月17日 · 1796 次阅读
An error occurred while installing mime-types (1.25.1), and Bundler cannot continue.
Make sure that `gem install mime-types -v '1.25.1'` succeeds before bundling.

运行完一个 gem install mime-types -v '1.25.1'紧接着运行 bundle install 之后有一个新的 gem 需要安装, 像这样 装完一个 又一个 , bundle 是为了方便管理 gem 么,有么有什么更加智能的解决方法呢!

备注:在本地运行没有这样的提示,在阿里云上运行一直是这样的情况,之前项目跑的时候一直正常。

共收到 3 条回复

推荐是用 RVM 的项目 gemset,在项目文件夹提添加 .rvmrc 指定 Ruby 版本和 gemset 仓库,系统就会自动调用

如果你用阿里云买的内存是 512 的话 会有这个问题。你需要增加交换分区。

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册