新手问题 ruby1.8.7 如何安装 nokogiri

yangman_wenzhu · 2015年01月15日 · 最后由 hooooopo 回复于 2015年01月17日 · 4172 次阅读

ruby1.8.7 如何安装 nokogiri

gem install nokogiri --no-ri --no-rdoc
ERROR:  Error installing nokogiri:
    nokogiri requires Ruby version >= 1.9.2.

这种方式需要 ruby 为 1.9.2 以上 可现在我是需要给 1.8.7 的项目安装这个插件

安装也是不成功的

用 ruby script/plugin install https://github.com/sparklemotion/nokogiri.git 方式安装 提示:MissingSourceFile (no such file to load -- nokogiri/nokogiri) 说明还是没有安装成功 请问在 ruby1.8.7 下怎么安装这个插件才能使之正常使用?

已经成功了 在 1.8.7 下 这样安装gem install nokogiri -v 1.4.3.1

把 gem 文件解压直接复制到库里试试?

ERROR:  Could not find a valid gem 'nokorigi' (>= 0) in any repository
ERROR:  Possible alternatives: nokogiri, nokorexi, nokogirl

你不看字的么……

@Rei 那只是一个错误之一.

@yangman_wenzhu 尝试找一个低版本的安装即可. 比如 gem install nokogiri --version 1.5.6

名字拼错了。

#2 楼 @Rei 哦 这个是看见的 后来自己在 console 重新运行了 不过是版本的问题 已经解决了 多谢指正

#3 楼 @lyfi2003 恩 是的 之前在低版本没有用过 今天上 rubygem.org 查看了 下对应的 ruby 版本发下 1.4.3.1 就是可以用的 就安装了这个 嘿嘿 多谢

建议升级下 ruby 先!

#7 楼 @Lucifer 恩 升级确实能解决 不过 我这个项目里面的东西太多 升级起来不方便 嘿嘿 安装低版本的 nokogiri 就可以了

有这时间都把 Ruby 升级完了

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册