新手问题 bcrypt error: Devise ruby 2.0 and rails 4.0![学习 rails!求助]

icodor · 2014年10月27日 · 最后由 icodor 回复于 2014年10月28日 · 1881 次阅读

has_secure_password 报错:

检查 Gemfile 然后 bundle install

#1 楼 @t_wu Gemfile:gem 'bcrypt-ruby', '3.0.1'

使用 gem 'bcrypt-ruby', '3.1.2' 就不报错!为什么 ruby rails gem 的版本都和教材一样还会有版本问题?

#3 楼 @icodor 命令行界面看起来不错啊,是使用系统自带的那个吗?

需要 登录 后方可回复, 如果你还没有账号请 注册新账号