Rails rake db:version 问题

luoyegufei · 2014年09月09日 · 最后由 hging 回复于 2014年09月09日 · 1285 次阅读

今天在查看数据库版本的时候发现一个问题:数据库版本显示的是 20140902,但是最新的 migration 是 20140901(其他的分支上的 migration 是 20140902),为什么我查到的数据库版本不是 20140901 呢?

...migrate 只会用新的吧. 因为其他分支有更新的 migration 并且对数据库进行过db:migrate的话. 就只会保存 0902 这个

#1 楼 @hging 这样的话会出问题吗?因为有的分支上的 migration 是其他分支上没有的

#2 楼 @luoyegufei 如果公用一个数据库的话会. 比如两个分支的表结构不一样. 这时候会有问题

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册