新手问题 RVM 安装以后提示 OpenSSL 无法找到

icodor · 2014年08月13日 · 最后由 ryanzhang 回复于 2014年08月15日 · 2346 次阅读

本机已有的环境是 ruby2.1 和 rails4.1,现在想装 ruby2.0 和 rails4.0,安装过程:

rvm install 2.0.0 --with-openssl-dir=$HOME/.rvm/usr

rvm use [email protected]_rails_4_0 --create

gem update --system 2.1.9 报错如下图:

谁让你安装 RVM 的时候后面要指定 --with-openssl-dir 呢!

正确的安装方式:

$ rvm pkg install openssl
$ rvm install 2.0.0
$ rvm use 2.0.0
$ ruby -v

谢谢!已解决!

@icodor 请问执行 rvm pkg install openssl 后,需要 reinstall 2.0.0 吗? 然后执行这两行 rvm use [email protected]_rails_4_0 --create gem update --system 2.1.9 最后执行 gem install rails 4.0 是吗?

#3 楼 @ryanzhang 是的!先 rvm remove 2.0.0 然后重新安装 2.0.0 !

@icodor 恩,那原来的 ruby 2.1.2 也需要重装吗?

#5 楼 @ryanzhang 不需要!能用!

#5 楼 @ryanzhang 没重装!目前还没发现有啥问题!

#8 楼 @ryanzhang 客气!相互学习!

@icodor 请问后来在第三章有遇到关于 selenium-webdriver 的问题吗?提示缺少 libiconv 之类的?

需要 登录 后方可回复, 如果你还没有账号请 注册新账号